Parallel Tools 高版本内核的安装失败的解决方法

Parallesl Desktop 个人认为它是macOS平台上最强大的一个虚拟机软件,国光曾经用这个虚拟机甚至可以流畅的打守望先锋,不过随着一些高版本的Linux内核的发行,PD Tools的安装可能并不是那么顺利。

前言

最近Kali Linux 出来2019.4的版本,外观变化蛮大,于是乎就打算使用PD虚拟机安装来尝尝鲜,但是安装PD Tools的时候遇到问题了,查看日志是内核相关的问题。找了些国外资料发现这种情况还是很多的,下面的解决方法同样也适用于 Ubuntu18.04、Ubuntu 19.10、Manjaro等高版本内核的Linux发行版

方法

解决这个问题得修改PD Tools的关键文件,然后重新打包PD Tools,但是这样折腾比较耗费时间,国光我这里直接附上我打包好的 PD Tools,大家直接安装即可(没有安装PD Tools 怎么拷贝到虚拟机里面呢???我这里是通搭建Web服务传文件进去的,当然直接SSH COPY也是可以的):

文件名:prl_mod.tar.gz 下载地址:蓝奏云

将这个文件替换掉PD Tools的kmods目录下的同名文件即可,然后就可以愉快的安装了。

原理

如果大家不放心用上面的prl_mod.tar.gz的话,也可以自己手动折腾一下,下面是相关细节:

从Parallels安装光盘中复制文件,并将它们放在某个文件夹中(例如〜/pd_fixed)

# 进入到 kmods 目录下
cd 〜/pd_fixed/kmods

# 解压并删除文件
tar -xzf prl_mod.tar.gz && rm prl_mod.tar.gz

# 编辑 prlfs.h 文件
vim 〜/pd_fixed/kmods/prl_fs/SharedFolders/Guest/Linux/prl_fs/prlfs.h

在16行插入如下内容:

#include <uapi/linux/mount.h>

最后插入完应该是这样一个效果:

...
#include <linux/fs.h>
#include <uapi/linux/mount.h>
#include <linux/types.h>
...

接着修改保存这个文件后重新打包一下就可以了:

# 进入到 kmods 目录下
cd 〜/pd_fixed/kmods

# 重新打包压缩
tar -zcvf prl_mod.tar.gz . dkms.conf Makefile.kmods

然后就可以愉快的安装了:

# 开放最高权限
sudo chmod -R 777 〜/pd_fixed/

# 安装pd tools
cd 〜/pd_fixed/ && ./installer

不出意外的话 现在是可以安装成功了,安装完成后重启虚拟机即可。


文章作者: 国光
版权声明: 本博客所有文章除特別声明外,均采用 CC BY 4.0 许可协议。转载请注明来源 国光 !
 上一篇
macOS pyenv入门使用记录 macOS pyenv入门使用记录
有时候开发需要在不同版本的Python中切换,这个时候就需要神器pyenv来简化我们的操作了。下面国光就来简单介绍一下入门操作,大道至简。 前言我们可以经常会问 Python2 还是 Pyton3 ??或者Python 3.6 还是 P
2019-12-17
下一篇 
国光的macOS配置优化记录 国光的macOS配置优化记录
每次安装完系统配置环境都是一个极为耗费时间的时期,特此写一篇文章记录一下macOS的常用配置,为后面再次配置少走一些弯路。 系统设置常用设置# 取消4位数密码限制 pwpolicy -clearaccountpolicies # 更
2019-12-11
  目录